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1. Overview
Dendrite is not a visual design tool or wysiwyg website creator / editor.
Dendrite is closer to a development environment than a content management system. It’s
for you if you want to hand-code or already have your code and want to manage the site as
code rather than visually. It contains a number of features and tools which will help you to
do this.
In a few clicks it can give you a website based on the Bootstrap example website. You will
need hosting and ftp or sftp credentials; server, username, password. (see 1.3 I want to start
with a website template and 4.1 How do I publish my site?)
They key feature, which gives the app its name, is that it can store text or code as ‘objects’.
Anything that appears in more than one place can be stored as an object and edited in one
place. A placeholder indicates an object’s position in the main file. You can click that
placeholder to edit the object. Objects can contain other objects.

When the site is compiled / published, placeholders are expanded before each file is
uploaded to the server.

Why might you *not* want to use a server-based CMS?
A CMS installed on the server has many advantages and has become the standard way to
manage a site. It allows distributed authorship, makes it very simple for a non-technical
person to update pages from any location, allows you to easily install various tools and
plugins.
However, as well as pros, there are cons.
Having a server-side CMS hacked is not fun. Compiling your pages before uploading to the
server is a more secure system than having an open-source content management system
on your server.
Speed is a ranking factor for Google searches. Building the pages on your own computer,
and uploading the compiled files means that your pages will be served as quickly as
possible when the page is viewed.
If you can write code and care about your site’s code being concise, clean and readable,
you may wish to be in control of your code rather than allowing software to generate
obfuscated and bloated html, css and js.

2. Getting started
1.1 I have website files (html, css etc)
Don’t use Dendrite to open the folder containing your files.
Choose Website > New (Empty) from the main menu.
Use the dialog to create a new folder for your Dendrite website (or choose an empty folder).
Dendrite will create its own directory structure within your new folder.
Choose File > Import from the main menu to choose your website files (html, css etc). You
can choose multiple files.
Go to 3. Creating objects

1.2 I want to start from scratch
Choose Website > New (Empty) from the main menu.
Use the dialog to create a new folder for your Dendrite website (or choose an empty folder).
Dendrite will create its own directory structure within your new folder.
Choose File > New from the main menu to create files such as html or css.
Type or paste your code.
Go to 3. Creating objects.

1.3 I want to start with a website template
Choose Website > New (With Template) from the main menu.
Use the dialog to create a new folder for your Dendrite website (or choose an empty folder).
Dendrite will create its own directory structure within your new folder and create a small
template website based on Boostrap. You can edit and publish these files.
Go to 3. Creating objects.

1.3 I want to open an existing Dendrite website
Choose Website > Open Existing… from the main menu. This menu item will only allow you
to open a folder if it already contains a Dendrite directory structure.
Once you have opened a website, it should then appear in the ‘Open Recent >’ menu which
is a quicker way to open it in the future.
1.4 I want to start with a duplicate of an existing Dendrite site
Use Finder to duplicate the website’s enclosing folder
Choose Website > Open (or the Open toolbar button) to open that duplicate project folder.

3. Creating objects
3.1 Why do I need to create objects?
You don’t need to create any. With your html and other supporting files in the files list, you
can edit those and publish them (see 4. Compiling and publishing).
You will however find that there are certain parts of a page which appear on multiple or all
pages, such as a navigation menu or footer text. When you make a change, it will be a
nuisance to have to make the same change on every page.
To take the footer text as an example, if you make that text into an object (or the whole
footer div if you like) and add a placeholder to every page, then you can edit the footer text
just once, and the new text will cascade to all pages when you compile and publish.
3.2 What should I make into an object?
It’s pointless to create an object if the code and/or text appears on just one place. Create
objects for text that a) you’re likely to want to edit and b) that appears in more than one
place.
3.3. Can an object contain an object?
Yes
3.4 Can I make the entire template into an object
No, because parts of the page will be unique. As an example, take the <head>. Some meta
information will be common to all pages, such as the favicon. But other tags such as title
and description will need to be unique. Therefore you’ll need to be selective. Create an
object from any code or text that appears in more than one place and that you’re likely to
want to change:

3.4 How do I create an object?
If the text already appears on the page, you can simply highlight it and choose New Object
With Selection…. from the main menu. A dialog will ask for the name for the new object and
a placeholder with that name will replace your selection. [A dialog will ask whether you’d like
Dendrite to search the other files for the object’s text, and replace any occurrences with a
placeholder for the object. ] [The new object will open in the editor. You can use the Back
button in the toolbar to return to the page.]
If the text/code doesn’t already exist, you can place your cursor where you want the
placeholder to appear and simply choose New Object… from the main menu. Once again a
dialog will ask for the name of the object. The new empty object will open in the editor ready
for you to add its content. You can use the Back button in the toolbar to return to the page.
3.5 How do I insert an object into a page/file/object?
With your file open in the main editor, simply drag and drop from the Objects list.

4. Images
4.1 How do I manage images?
Since version 1.3.0, the left-hand column contains a table which lists the images in the /
images/ folder within the site’s directory structure. You can put images directly into that
images folder, they will appear in the table.
Alternatively you can add images and resize them at the same time as described in 4.3
below.
4.2 How do I add images to a page or object?
You can drag and drop an item from the images table into the main editing view. An <img>
tag will be inserted, pre-populated with the image src. The alt attribute is there for you to fill
in. As things stand you’ll need to add other attributes such as srcset, class, style or title if
you need them.
4.3 How do I use Dendrite’s built-in image resizing tool?
Since version 1.4.0, Dendrite has the SharpResize tool built in, which allows you to drag and
drop or paste images. You can specify a size, with proportions locked or unlocked. If
unlocked you can choose to crop the image or add space to the sides or top/bottom (white,
black or grey). It resizes the image using Lanczos resampling for a crisp resized image.
Open the dialog using File > New Image… or the Add Image button on the Insert Card
dialog. Drag and drop or paste your image.

You can further enhance the image with a host of controls:

It’s necessary to give a name. The minimum you need to give is a ‘base name’. An extension
will be added according to the file format under Output format (there’s a slider there too for
jpg quality). If you’ve chosen to save other sizes (eg 2x, 3x) then the appropriate suﬃx will
be added to those variations (ie myimage-2x.jpg). If you do specify a format in the name
field, that overrides the Output format button (and changes it if necessary).
The OK button will save your image to the /images/ folder.
Images created this way will be transferred to the server when you compile and publish the
site (see 5.1) Note that any other images modified or added to the /images/ folder outside of
Dendrite won’t be transferred automatically.
If you’re using this tool to create a thumbnail for a card, the image base name will be
inserted into the card dialog’s id field and the image fields will be autocompleted.
The intended workflow is:
• Insert Card (opens card dialog)
• Add Image (opens SharpResize dialog)
• Paste / drag your image, make adjustments and type a base name
• OK the image dialog (saves the image, closes the dialog and completes the id and image
fields of the card dialog)
• Complete the rest of the card dialog and Insert (closes the card dialog, creates the object,
inserts an object placeholder into the page/object that you have open in the main editing
pane.)
Any images that you import, or create using the SharpResize tool, will be uploaded when
you publish a page or the site. (Note that it will automatically upload images that have been
added via Dendrite since you last uploaded one or more pages). If you don’t want this to
happen, there’s a checkbox in Dendrite’s preferences.

5. Compiling and publishing
5.1 How do I publish my site?
Choose Compile and Publish from the main menu, its shortcut cmd-R or the Compile
toolbar button.
In all cases, when the compile finishes, a dialog will ask for the server and other ftp / sftp
details. See also: 6.2 Can I compile my pages but then publish them using another
program?
You can cancel at this point if you want to use an ftp program for publishing, or if you want
to compile without publishing.

6. Advanced topics
6.1 Can my site have a directory structure?
Yes. When you create or import your page into Dendrite, and the dialog asks for the name of
the page, give the page name along with any directories, relative to the root of the website,
for example:

This also applies if you like to keep multiple css files in a folder called css, for example.
Note that even if you intend the url of a web page to be mac/scrutiny/, in Dendrite the page
must have a filename with an extension (as in the shot above).
Internally, the uncompiled pages will have a flat directory structure, but once compiled, the
pages will be within folders matching your directory structure.
NOTE
In this early version, if you use the above techniques to create a directory structure, the
compiled pages will only be ftp’d successfully if the directory structure already exists on the
server, so you will have to create those folders on the server manually using an ftp app. A
future version should do this for you automatically.
6.2 Can I compile my pages but then publish them using another program?
Yes. The compiled pages will be within the folder that you created for your Dendrite project.
If your site has a directory structure (see 5.1) Then folders will exist matching that directory
structure. Note that Dendrite also creates its own folders (pages, objects, data)
6.3 Can Dendrite handle my images?
In this early version, it can’t. Feel free to create an images folder within your website folder,
but you will have to write your own img tags within your html and ftp them manually to your
server. A future version should allow you to import images, drag and drop to create img tags
and ftp them for you.
6.4 Some or all of my pages are php, not html

No problem. Simply import them, edit them and publish them in the same way as html
pages.
6.5 Cards
This feature allows you to add structured data.
For example, if you have a page that lists news stories, each news story might have a
heading, thumbnail image, paragraph or two of text and a link, like this.

Insert > Card or the toolbar button Insert Card opens a dialog which gives you fields for
these things.

When you have finished with that dialog, a placeholder is inserted in your page.
To edit the card, click the placeholder, the dialog will re-open to allow you to edit the fields.
The placeholder has a name which includes the id field, so make sure that’s unique and
descriptive. Try not to edit that id after you’ve inserted the card for the first time.

A card template defines the html for a card (into which your fields are inserted at compile
time). You may have any number of card templates, and they may not necessarily use all of
the fields available on the dialog.
When you create an empty or template website (see 1.1, 1.2 and 1.3) Dendrite will create
some default card templates. They’re within your website’s folder, in a subfolder called
templates. You can edit these or create new ones.
You have a specific set of templates for each website. You’ll get the default set each time
you create a new website. If you want to use a custom card template for multiple websites,
just make a copy from one templates folder to the others.
The drop-down list of templates at the top of the card dialog will contain a list of the
templates available for that website (listed by their filename, minus the .txt extension)
A template is a .txt file containing the html template for your card, with placeholders for your
fields, in the form <% ddt:fieldname %>. Look at the existing templates to see how they
work.
The field names (corresponding with the dialog you can see in the screenshot above) are:
• id
• title
• image, 2ximage, 3ximage
• alt
• body
• href
• linktext
• linktarget
• date
• subtitle

7. Downloading and licensing
The latest version of the software will be at https://peacockmedia.software/mac/dendrite
At time of writing this version of the manual, Dendrite is free to use and free to distribute as
shareware. That is, unchanged and in its original package (dmg), also unchanged.

8. Version control
0.1 | 23 July 2020 | Shiela Dixon | First draft
0.2 | 8 Aug 2020 | Shiela Dixon | Many additions. Included with first public release of app
0.3 | 14 Sep 2020 | Shiela Dixon | Inserts section on Images
0.4 | 18 Sep 2020 | Shiela Dixon | Adds details of SharpResize tool to the Images
section.
0.5 | 3 Oct 2020 | Shiela Dixon | Minor change to images section

